Linuxinstallation auf Gericom Webboy

Diese Seite wurde verfasst von Jerome Griessmeier (jerome_at_griessmeier.de)

 


Haftungsausschluss
Vorwort
Ausstattung
X-server
Netzwerk
Modem
Sound
 

 







Haftungsausschluss:

The author disclaims all warranties with regard to this document, including all implied warranties of merchantability and fitness for a certain purpose; in no event shall the author be liable for any special, indirect or consequential damages or any damages whatsoever resulting from loss of use, data or profits, whether in an action of contract, negligence or other tortious action, arising out of or in connection with the use of this document.

Vorwort:

Ich habe nicht sehr viele verschiedenen Distributionen ausprobiert, da die erste auf Anhieb funktioniert hat. Dies war die Professional-Edition von SuSE in der Version 7.1 . Der Hautgrund der mich letztlich dazubrachte das GericomNotebook zu kaufen war die zum Kaufdatum eine sehr gut Hardwareaustattung zu einem attraktiven Preis hatte. Zum Zeitpunkt des kaufs war ich mir noch gar nicht sicher, ob ich denn überhaupt eine Linux Version mit grafischer Oberfläche zum laufen bekommen würde, aber Berichte von anderen Linux Usern machten mir dann Hoffnung den SIS grafikchip doch ohne grösseren Ärger zum laufen zu bekommen.Nach nun 4 Wochen mit diesem Notebook kann ich doch guten gewissens das Gericom Notebook mit einsatz von Linux weiterempfehlen. Das einzige was ich unter Linux noch zum laufen gebracht habe ist das Modem, doch dazu steht weiter unten ein bisschen mehr.
Geholfen hat mir ausserdem die Webseite von Fabio Tosques (sep. 2008: Die Webseite ist leider nicht mehr existent) der ebenfalls einen Gericom Laptop mit Linux benutzt, allerdings konnte mir seine X-Serverkonfiguration leider nicht weiterhelfen.

Ausstattung:

o.k. nun zum interessanteren Teil. Was ich im April 2001 (for 2999,- DM bei MediaMarkt)
gekauft habe läuft mit folgender Hardware.

Prozessor:
Processor: 850Mhz PIII
Corelogic: SiS-Chipset mit integriertem Video, Audio, Netzwerk und ModemController
Bus Architektur: 66Mhz frontside-bus (100Mhz ready)

Harddisk:
Ich bekam eine 12GB grosse Partition auf der Windows Millenium vorinstalliert war.

CD/DVD-ROM:
cdromspeed: 24x
dvdromspeed: nicht weiter spezifiziert

LCD Bildschirm:
ein 13,3-inch XGA active-matrix TFT display unterstützt eine Auflösung von bis zu 1024x768 pixeln bei einer Farbtiefe von maximal 16Mio. Farben

Grafikchip:
SiS 630 mit integriertem 2D/3D AGPBus grafikbeschleuniger: UltraAGP architecture graphics capability (was einem 4x AGP gleichen sollte).
Das Notebook gestattet auch ein Anschliessen eines externen Monitors (zumindest laut beschreibung, da von mir noch nicht getestet)

Audio Chipset:
SiS 630 mit integreirtem Sound Controoler: 64-Voice Polyphony Wavetable Synthesizer; DirectSound 3D beschleuniger für IID, IAD und Doppler effects.


Modem Chipset:
SiS 630 mit integriertem Soundcontroller.
Geschwindigkeit: V.90 / K56flex und beim Download bis zu 56000 bps;


LAN Network Adapter:
SiS 630 mit integrierem PCI Fast Ethernet für 10Base-T and 100Base-TX Netzwerke. Unterstützt standard PnP Funktion: M$ Win 9x Plug'n'Pray etc.


PC Card PCMCIA Controller:
O2Micro OZ 6812/ 6912 controller
TYPE II/III PC mit Card Bus 1.0 interface, etc.

und los ging es:
Die Installation von SuSe-Linux verlief ohne grössere nennenswerte Probleme.Es war sogar möglcih die Platte mit hilfe von yast2 neu zu partitionieren ohne meine Daten auf der Windowspartition zu verlieren.

X-Server:
Den X-Server bekommt man vermutlich folgendermassen am einfachsten zum laufen:
Mein Laptop ist für eine 1024x768er Auflösung bei einer Farbtiefe von konfiguriert.
Installation möglichst mit yast2 beginnen. Sobald yast2 einen x-server installieren möchte muss "ohne x-server" installieren ausgewählt werden.Kopiert euch einfach nach beenden der Installation diese XF86Config nach/etc auf euren Rechner. Nun müsst ihr eure ow you /etc/lilo.conf editieren und dabei den vga-Parameter von vga=normal auf vga=791 setzen.
> lilo
(dieser Befehl zwingt euren Rechner die eben veränderte Konfiguration neu einzulesen)
Dies sollte euren Rechner dazu bringen schon direkt beim booten in einen 16Bit Modus zu springen, was ihr auch am Pinguin der dann in der linken oberen Ecke auftauchen sollte überprüfen können solltet. Und ändert die Login Konfiguration im yast von ascii auf einen grafischen login oder ändert den Wert direkt in der /etc/inittab, damit der x-server auch beim Hochfahren direkt gestartet wird.
Nun muss noch ein Paket nachinstalliert werden (am einfachsten mittels yast).Und zwar xfbdev dass in der serie xsrvnow gefunden werden sollte. Nun solltet ihr in der Lage sein sax mit folgenden Kommandos aufzurufen.
> sax -s fbdev
Wenn ihr wollt könnt ihr nun eure Konfigurationauf mit folgendem Befehl testen:
> startx -- -bpp 16
O.k. jetzt ist es fast geschafft! Rebootet euer System und ihr solltet von eurem grafischen LoginPanel begrüsst werden.
Wenn nicht, könnt ihr noch folgendes probieren::
> XF86_FBDev -bpp 16
> ln -s /usr/X11R6/bin/XF86_FBDev /var/X11R6/bin/X
Wenn nun alles so wie erhofft funktioniert gibt es noch eine Kleinigkeit zu tun, geht in die /etc/rc.config.d/apmd.rc.config/apm und setzt APMD_LEAVE_X_BEFORE_SUSPEND="yes" .

Netzwerk:
Die Netzwerkksrte sollte ohne grössere Probleme lauffähig gemacht erden können.Es müssen lediglich die richtigen Module nachgeladen werden, die der SuSE-Version 6.4 bereits im Kernel enthalten sind. Andere Distributionen und Besitzer älterer SuSE-Versionen müssen sich erst einen neuen Kernel kompilieren. Ansonsten geht es folgendermassen weiter.
> modprobe sis900
um den Treiber zu aktivieren und dann noch
> ifconfig eth0 192.168.0.99 netmask 255.255.255.0 up
um die persönlichen Netzwerkeinstellungen zu konfigurieren, und diejenigen die auch ein Gateway brauchen sollten noch folgendes eingeben und einen Eintrag in der /etc/route.conf vornehmen
> route add -net default gateway 192.168.0.1

Modem:
Habe das Modem jedoch leider noch nicht zum laufen bekommen, da es sich um ein sogenanntes winmodem handelt, dass momentan noch nicht unterstützt wird. Falls es doch jemand hinbekommen sollte würde ich mich über Infos hierüber sehr freuen.
Das einzige was ich zu diesem Thema gefunden habe ist eine Website der es Treiber für einige winmodems gibt.
Leider wurde die Webseite aus dem Netz genommen

Sound:
Der Sound lies sich bei mir ohne Probleme und mit Hilfe von yast2 konfigurieren.

So, have a lot of fun ...............................